Solucionado el Error de "Dependencias Incumplidas" o "Dependencies Not Met"




Ya tenemos solución al problemático error que ha aparecido recientemente en todas las versiones "Gotham" de XBMC.

Siempre que queríamos instalar un plugin de vídeo nos aparecía el mensaje de "Dependices Not Met" o "Dependencias Incumplidas".

DEPENDENCIAS INCUMPLIDAS

Y si nos dirigíamos al repositorio de general de XBMC y buscábamos plugins de vídeo, observábamos como muchos de ellos aparecían como "Rotos" o "Broken".

Ahora explicaré como poder solventar esta incidencia y poder seguir disfrutando de XBMC sin problemas.


1. Nos descargamos el archivo .ZIP que adjunto mas abajo.


2. Abrimos XBMC y nos dirigimos a :

Sistema - Addons - Instalar desde archivo .ZIP


3. Buscamos el archivo que hemos descargado y lo pulsamos para que XBMC empiece a instalarlo.



4. Pasados unos 5 segundos, salimos de XBMC (reiniciamos)



5. Volvemos a entrar y ya podemos instalar sin problemas los plugins de vídeo.



Descarga para XBMC

Laser

Laser

Apasionado de la tecnología, del deporte y de todo lo que rodea a este sorprendente software llamado KODI / XBMC.

Recibe las últimas noticias :

63 comentarios

Write comentarios
krist2108
AUTHOR
8/11/13 18:05 delete

no se me quito el error, llevo casi dos meses tratando de configurar mi xbmc y la vdd es que no he logrado mucho me podran ayudar via remota les agradecere mucho saludos desde mexico

Reply
avatar
Jose A.
AUTHOR
8/11/13 20:11 delete

Si señor solucionado el problema, eres un fenómeno, muchas gracias.
Tengo otro problema ¿porque en windows xp veo todos los canales y en mi Android tv no?
por ejemplo cuando pincho en mi android tv Eventos dep. se me cierra el XBMC y en el pc va perfecto y algun otro canal no lo carga el Android tv. Muchas gracias por tu trabajo.

Reply
avatar
Laser
AUTHOR
11/11/13 17:20 delete

Si, dime donde te has quedado "atrapado" ?

Reply
avatar
Laser
AUTHOR
11/11/13 17:22 delete

Hola,

Cierto, parece que hay algunos servidores que si se combinaban equipos Android con ciertas versiones de XBMC, daba como resultado el cierre total del programa.

Pero lo que comentas que otro canal no carga, seguramente sea o porque ha dejado de emitir o porque requiere de librería actualizada.

Para cualquier cosa aqui estoy para ayudarte.

Un saludo.

Reply
avatar
manu
AUTHOR
11/11/13 19:03 delete

A mi tambien me sigue dando el error de dependencias imcumplidas con el xbmc frodo de linux, al instalar esta descarga que pones y con el livestream.

Reply
avatar
manu
AUTHOR
11/11/13 20:17 delete

Ya lo solucione reinstalando el xbmc, es que le mire el log y era cosa del simple downloader, estaba roto el paquete, asi que elimine la instalacion de xbmc y lo reinstale de nuevo, añadi el jdwonloader del repositorio que te viene, y ya segui los pasos de configuracion y ya me va. Gracias por este addon es genial.

Reply
avatar
Ayu18
AUTHOR
12/11/13 19:45 delete

Laser, ¿ya sabes cuál es la version XBMC más estable para Android (Minix Neo X5)?

Reply
avatar
ful
AUTHOR
12/11/13 21:46 delete

Hola a mi con rspbmc no me deja instalarlo y no hace nada .y cuando intento instalar cualquier otro plugins me dice dependencia imcumplidas solo e podido instalar pelisalacarta y tv alacarta y no me deja inatalar ningun otro mas

Reply
avatar
Nairyd Parra
AUTHOR
13/11/13 17:56 delete

estoy en ima mac con la versión de XBMC 13.0 hagolospasos que indican arriba y aun así me da error! alguna ayuda extra¿?

Reply
avatar
Laser
AUTHOR
22/11/13 20:51 delete

Hola de nuevo,

Continuáis con el mismo error?

Reply
avatar
Laser
AUTHOR
25/11/13 12:45 delete

Dame mas datos Ruben ya que no he visto tu duda anteriormente...

Reply
avatar
Laser
AUTHOR
28/11/13 16:44 delete

Perfecto Manu :)

Reply
avatar
Anónimo
AUTHOR
3/12/13 18:13 delete

hola
a mi me pasa igual lo intento instalar y no me sale lo de addon activado, o es que no debe salir eso, es que quiero instalar el de nigh y no me deja pero otro addon si que me deja instalarlos, es este de solucionar el error

Reply
avatar
4/12/13 3:11 delete

Yo en mi tab 3 de samsung no puedo instalar los addon dentro de la apli no hay manera dice el mensajito dichoso

Reply
avatar
4/12/13 4:03 delete

Yo ya e consegido instalar todo pero veo unos segundos y se me cae la apli me puede ayudar alguien

Reply
avatar
Jorge Pascual
AUTHOR
9/12/13 18:56 delete

Hola a todos.
Tengo el minix X5 y al instalar la nueva versión xbmc especialmente para él me sale el problema de las "dependencias constantemente". He probado a instalar el archivo que has colgado y sigo con el mismo problema. He cambiado de versión de xbmc y sigue. Incluso he cambiado el firmware del aparato y sigue con el mismo problema. Estoy desesperado. El caso es que nunca me había pasado y he probado ya muchos xbmc. A ver si me puedes ayudar. Gracias y un saludo.

Reply
avatar
10/12/13 7:58 delete

Hola,queria decirle que me sale siempre independencias incumplidas,me baje el scrit pero no se soluciona,lo tenia descargado antes y me iba perfecto hasta que lo desistale y siempre me sale este mensaje,por favor podrian decirme la solucion me bajado toda las versiones, yo tengo windos 7

Reply
avatar
Anónimo
AUTHOR
10/12/13 11:05 delete

A mi también me pasa con plugin livestreams, cuando antes no me pasaba. He instalado varios xbmc y en todos me pasa. el script para solucionar el problema no me lo coge ,compre el mele para ver el futbol imaginaros mi fustración.

Reply
avatar
Laser
AUTHOR
10/12/13 11:26 delete

Tranquilos que esto tiene solución, para empezar que versión exacta de XBMC teneis instalada?

Para saberla iros a SISTEMA / INFO DEL SISTEMA y ponerme aqui lo que os aparece con letras azules.

Otra cosa para los que os falle algun plugin como el de LIVESTREAMS, probar a instalarlo manualmente la carpeta en lugar de hacerlo dentro de XBMC, para saber donde pegarlo mirar la ruta de vuestro equipo aqui :

http://pluginsxbmc.blogspot.com.es/2013/01/como-instalar-plugins-scripts-y-skins.html

Reply
avatar
Patxi
AUTHOR
10/12/13 13:31 delete

Instalándolo manualmente, el plugin aparece en Vídeos - Add-ons, pero al ejecutarlo aparece un nuevo error: Fallo en el script: plugin.video.live.streams

Reply
avatar
Coordinador
AUTHOR
10/12/13 13:46 delete

Hola, muchas gracias por el apoyo, lamentablemente a mi tampoco me ha solucionado el problema de las dependencias incumplidas. Lo tengo instalado en una Energy Sistem S10 dual.

Reply
avatar
Patxi
AUTHOR
10/12/13 13:48 delete

Por cierto, utilizo Android 4.1.2 y XBMC 12.2 Git:20130502-32b1a5e.

También he probado a ponerle las URL de los XML que dabas y obtengo el mismo error.

Reply
avatar
Laser
AUTHOR
12/12/13 11:07 delete

Patxi por favor comentalo aqui mejor :

http://pluginsxbmc.blogspot.com.es/2013/03/livestreams-mod-by-pluginsxbmc.html

Es que si mezclamos los difererentes errores que nos aparecen no nos vamos a entender.

En esta entrada estamos hablando de otro error diferente que es el de "Dependencias Not Met".

Reply
avatar
Laser
AUTHOR
12/12/13 11:07 delete

Y que versión de XBMC usas?

Reply
avatar
Andrea Fdz
AUTHOR
21/12/13 22:37 delete

Hola,ya solucionaste esto?yo tengo el mismo problema y tb ando moskeada.....
Si me pudieras ayudar....gracias

Reply
avatar
7/1/14 14:58 delete

Hola por favor Ayúdame, he probado instalarme manualmente y desde archivo y no hay forma sigue saliendo ese mensaje cuando añado un add-on de video. TENGO Frodo 12, tambien probé con otras versiones me sigue saliendo "Dependencias Incumplidad"

Reply
avatar
Laser
AUTHOR
14/1/14 20:32 delete

Alfredo probaste la vesion 12.3?

Reply
avatar
Laser
AUTHOR
14/1/14 20:32 delete

Patxi prueba con la 12.3 que solventa varios errores de la 12.2 y este puede ser uno.

Reply
avatar
Jose Mª Ruiz
AUTHOR
14/1/14 21:09 delete

Galaxy tab 2 10.1 y XBMC 12.3 "frodo" con script instalado sin problemas, pero sigue con lo mismo.

Reply
avatar
Anónimo
AUTHOR
15/1/14 18:37 delete

No soy capaz de instalar nada. Y al instalar este archivo no me hace nada... Me doy por vencido? Tengo el xbmc openelec frodo 12 en un portátil. Con discoduro pelao sin windows ni nada.

Reply
avatar
Jose Mª Ruiz
AUTHOR
15/1/14 20:24 delete

Lo mio solucionado, desinstalar xmc y volver a instalarlo, no hizo falta el script, otro fallito mas de la TAB 2

Reply
avatar
Anónimo
AUTHOR
16/1/14 20:25 delete

yo tras hacer todo lo que se decia no consegui arreglarlo. tengo la 12.2 y en uno de los comentarios se dijo que reistalando se solucionaba, y... A SI FUE. Reinstalando se arreglo. Ya aprovecho, mi portatil tiene salida VGA pero al conectar el cable a la tv no se ve o no detecta el portatil me imagino, y en configuracion no veo nada sobre la conexion de tv. alguna ayudita?????

Reply
avatar
Anónimo
AUTHOR
16/1/14 21:20 delete

Por fin parece que lo he logrado solucionar, el zip esta mal, se descomprime en dos carpetas, la solicion es descomprimirlo , entrar en la carpeta descomprimirda y y copiar la ultima carpeta, de forma manual en addons. No se si me he explicado bien pero creo que es ese el problema.

Reply
avatar
Anónimo
AUTHOR
16/1/14 22:24 delete

solucionado reinstalando!

Reply
avatar
Anónimo
AUTHOR
16/1/14 22:25 delete

asi es. gracias!

Reply
avatar
29/1/14 3:28 delete

buenas, os cuento mi problema aver si sabeis guiarme porque llevo toda la noche liado y estoy que me tiro de los pelos...llevo meses usando xbmc en mi raspberry pi y todo de maravilla con varios add ons entre ellos live streams y pelis a la carta, el caso es que esta noche me decidi a reinstalarlo todo porque tenia mucha porqueria de aver estado trasteando y eso, e hecho toda la instalacion normal desde cero y ahora al poco de estar encencido el xbmc me da un error del weather underground, diciendome: add on marcado como roto en el respositorio, ¿ desea deshabilitarlo en el sistema?
si o no ? le da a lo que le de vuelve a salir al cabo de unos minutos... ignore esto y fui a instalar el live stream, y me salio el famoso error de dependencias incumplidas, e intentado instalar el archivo que se dice en este post pero no hace nada de nada ni me tira error ni nada simplemente no dice nada, el unico add ons que me deja instalar sin problemas es el de pelis a la carta, como e leido algo de que se solucionan cosas instalando el de the trailers me dirigi a "conseguir mas" para instalarlo y mi sorpresa fue que cuando entre en el repositorio estaba vacio...no sale nada, pfff quiero pensar que simplemente todo esto es porque se a caido el repositorio de xbmc pero no se llevo toda la noche en planta y e probado ya de todo...muchas gracias de ante mano y disculpen las molestias !

Reply
avatar
Anónimo
AUTHOR
31/1/14 20:46 delete

Hola laser,
estoy intentado instalar este plugin para que no me salga el error a las dependencias incumplidas pero continua saliendo siguiendo los pasos que indicas.
tengo la raspberry con raspbmc version 12.2.

Reply
avatar
Anónimo
AUTHOR
5/2/14 11:23 delete

he instalado el sportsdevils y cuando quiero entrar a ver algun canal me aparece NO STREAM AVAILABLE, que he hecho mal o no he hecho? os agradeceria vuestra ayuda.

Reply
avatar
Anónimo
AUTHOR
5/2/14 15:22 delete

a que te refieres a la ultima carpeta?
si lo descomprimo solo me sale esta carpeta ''script.module.parsedon'' y dentro de ella solo hay una carpeta llamada ''lib'' es esta? que dentro esta este archivo CommonFunctionspy
gracias por la atencion

Reply
avatar
Laser
AUTHOR
5/2/14 16:15 delete

No has hecho nada malo, es solo que ese plugin le falta mantenimiento.

Reply
avatar
Laser
AUTHOR
5/2/14 16:16 delete

Los que aún tengáis Error de Dependencias intentar si podéis actualizar la versión de XBMC a la 12.3

Reply
avatar
Anónimo
AUTHOR
6/2/14 18:34 delete

Pero la rasbmc solo esta en la version 12.2 que hacemos?

Reply
avatar
Anónimo
AUTHOR
6/2/14 18:36 delete

con la version 12.3 no hace falta de instalar esta solucion o si tenemos la 12.3 ahora si que podriamos instalar esta solucion?

Reply
avatar
Jesuskfc
AUTHOR
9/2/14 13:50 delete

Buenas! Yo estoy con raspbmc 12.2 e intento instalar el script y ni si quiera me lo instala. :S

Reply
avatar
Jesuskfc
AUTHOR
10/2/14 0:02 delete

Buenas noches! Tras varios intentos he descubierto ( en otro post de esta pagina) la manera de conseguir que funcione, la clave esta descomprimir el archivo y meterlo directamente a la raiz del xbmc.

Os dejo los sistios por sistemas operativos:

Windows XP :
C: / Documents and Settings / Nombre de Usuario / Datos de Programa / XBMC / Addons /
Windows Vista y Windows 7 :
C: / Users / Nombre de Usuario / AppData / Roaming / XBMC / Addons /
Android :
/ Sdcard / Android / data / org.xbmc.xbmc / files / .xbmc / Addons /
Mac :
/ Applications / XBMC.app / Mostar contenido del paquete / Contents / Resources / XBMC / addons/
Apple TV :
/ Library / Application Support / XBMC / Addons /
iOS :
/ Private / var / mobile / Library / Preferences / XBMC / Addons /
Linux :
/ .xbmc / Addons
Raspberry Pi :
/ home / pi / .xbmc / Addons
Raspberry Pi “OpenElec” :
/ Storage / .xbmc / addons /
XBOX :
E: / Apps / XBMC / Plugins

Reply
avatar
Jesuskfc
AUTHOR
10/2/14 0:04 delete

Decir que ahora me surge otro problema, es que cuando accedo al addon o trato de añadirle una url me da otro error: fallo en el script plugins.video.live.streams

Le he metido un par de scripts que por lo visto solucionaban el problema, pero me siguen dando fallo.

A ver si entre todos avanzamos jeje

Reply
avatar
Anónimo
AUTHOR
10/3/14 17:26 delete

hola to tengo un apple tv2 y estoy intentando instalar el livetv y me sale lo de las dependencias, tengo el xbmc 12.3 y no hay manera de instalarlo

Reply
avatar
17/3/14 9:37 delete

Hola, ayer desinstalé la versión 12.2 e instalé la 13.0 (por la aceleración hardware) y solo me dejó instalar pelisalacarta, el resto me da error de dependencias o fallo en el script.

¿tengo que volver a la 12.2?

Si desinstalo y borro toda la carpeta de xbmc con todos los ficheros que hay, ¿Se solucionará?

Gracias Laser.

Reply
avatar
Kinet
AUTHOR
30/3/14 20:37 delete

En mi samsung galaxy s 2 no funciona, uso versión 13.0 gotham.

Reply
avatar
Anónimo
AUTHOR
3/4/14 2:33 delete

gracias laser a mi si me funcionan los addons en gothan acabo de instalar livestream manualmente y funcionando gracias nuevamente un saludo desde mexico

Reply
avatar
Anónimo
AUTHOR
8/4/14 0:51 delete

Se puede solucionar fácilmente reinstalando raspbcm pero desde la propia raspberry, que baje la ultima actualización disponible.
1- http://www.raspbmc.com/download/
2- Descargar el Network image
3- Te lo instalas en la SD con el Win32DiskImager (por ejemplo).
4- Espera los 20-25min que tarda en configurarse todo y listos.
Adiós problema de dependencias

Reply
avatar
Anónimo
AUTHOR
14/4/14 0:03 delete

ironico, cuando lo quiero instalar me dice "dependencies not met"

Reply
avatar
29/4/14 13:02 delete

Esta es la solucion, y os puedo asegurar que funciona.
http://forum.mashupxbmc.com/showthread.php?1371-XBMC-Gotham-Solution-to-quot-Dependencies-not-met-quot-problems-while-installing-addons

Reply
avatar
jhj001
AUTHOR
29/4/14 18:41 delete

Hola, lo he logrado tal y como se describe arriba: Jesuskfc

Android :
/ Sdcard / Android / data / org.xbmc.xbmc / files / .xbmc / Addons /
descomprimiendo el script e introduciendo directamente la carpeta.
La solución de Jose Manuel, también es válida, pero en mi caso ya tenia 2.10

Reply
avatar
Laser
AUTHOR
3/5/14 16:23 delete

Gracias Jose Manuel por compartirla :)

Reply
avatar
Anónimo
AUTHOR
3/5/14 17:37 delete

Hola, tengo instala la version gotham RC 1, y cuando quiero intalar X-NAVI desde FUSION me da error de dependencias....

Ya baje el archivo que subiste arriba e hice los pasos pero aun asi me da el error, me podrias dar una mano en esto?

Muchas gracias...

Reply
avatar
Anónimo
AUTHOR
9/6/14 18:00 delete

Ya lo probé con un plugin y sí que funciona. Pero con cada plugin que quiera instalar me toca hacer lo mismo??? es decir tener que editar el addon.xml de cada plugin??

Reply
avatar
6/9/15 9:44 delete

hola amigo laser mi problema es que yo tengo el kodi version 15.0 isengrad y estoy intentando instalar el addons f4mtester me sale el aviso de dependencias incumplidas hice lo que sugieres que reinicie uno y no me sale o aparece me podrias ayudar y gracias

Reply
avatar
Anónimo
AUTHOR
27/10/15 8:55 delete

Esta solucion fue la unica que funciono para mi,
Copie la carpeta del plugin directamente, y despues abri el kodi y lo habilite como si lo estuviera instalando normalmente,
Videos/addons/ add from zip file etc. y por fin, comenzo a instalarse, muchas gracias.

Reply
avatar
Wilson
AUTHOR
6/1/16 18:19 delete

el link al foro ya funciona, me podrias decir que hay que modificar en el addon.xml, gracias

Reply
avatar
Anónimo
AUTHOR
23/1/16 9:55 delete

A mi me habia pasado lo mismo pero ahora gracias a ti ya lo solucione

Reply
avatar
26/9/16 16:21 delete

Buenas tengo mínix x5 con el xbmc 12.2, instalado, me he bajado tu archivo le doy a instalar y no parece que haga nada no me sale pantallita abajo de q se ha instalado algo. Aún así después de esto sigue la cosa igual, intento instalarme la addon ufc.finest y me pone q roto depencias incumplidas. Alguna solución? Gracias

Reply
avatar